VYOS

https://www.vyos.io
 
 

VYOS Installation

install image  

VYOS Configuration

configure  
set service ssh port '22' SSH
set system host-name TDRTR01 Add Hostname

set interfaces ethernet eth0 address '172.16.10.254/16'  
set interfaces ethernet eth0 description 'PRIVATE'  
set interfaces ethernet eth1 address dhcp  
set interfaces ethernet eth1 description 'WAN-GORDONNET'  

set nat source rule 100 outbound-interface 'eth1'  
set nat source rule 100 source address '172.16.0.0/16'  
set nat source rule 100 translation address masquerade  

 
set service dhcp-server disabled 'false'  
set service dhcp-server shared-network-name TDNET1 authoritative  
set service dhcp-server shared-network-name TDNET1 subnet 172.16.10.0/24 default-router '172.16.10.254'  
set service dhcp-server shared-network-name TDNET1 subnet 172.16.10.0/24 dns-server '172.16.0.1'  
set service dhcp-server shared-network-name TDNET1 subnet 172.16.10.0/24 dns-server '172.16.10.254'  
set service dhcp-server shared-network-name TDNET1 subnet 172.16.10.0/24 domain-name 'tdnet.com'  
set service dhcp-server shared-network-name TDNET1 subnet 172.16.10.0/24 lease '86400'  
set service dhcp-server shared-network-name LAN subnet 172.16.10.0/24 start 172.16.10.100 stop '172.16.10.199'  

 
set service dns forwarding cache-size '0'  
set service dns forwarding listen-address '172.16.10.0/24'  
set service dns forwarding name-server '208.67.222.222'  
set service dns forwarding name-server '208.67.220.220'  
set service dns forwarding allow-from '172.16.10.0/24'  

 
set protocols rip interface eth0  
set protocols rip interface eth1  
commit  
save  
exit  
   

VYOS Update

add system image https://downloads.vyos.io/rolling/current/amd64/vyos-rolling-latest.iso  
   

Other Commands

show version  
show system image  
delete system image